CNF Upgrade times out earlier than configured timeout threshold value in TCA Manager UI
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CNF Upgrade times out earlier than configured timeout threshold value in TCA Manager UI

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Article ID: 409188

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

During CNF LCM Operation Upgrade the timeout is set in TCA Manager UI as mentioned below

  1. Log in to the VMware Telco Cloud Automation web interface.
  2. Select Inventory > Network Function and select the CNF to upgrade.
  3. Click the ⋮ symbol against the CNF and select Upgrade.
  4. Set the Timeout in minutes.
  5. Despite setting the timeout to higher value (in minutes), the upgrade workflow times out earlier than the configured threshold in TCA Manager UI.

Environment

TCA 3.2

Cause

The Timeout parameter is not set in TCA Control Plane.It is mandatory to define the upgrade timeout in both the TCA Control Plane and TCA Manager.

Resolution

  1. In case the helm charts may take more than 1 hour to execute, use global setting API Call to change the timeout for chosen LCM operation in relevant TCA CP before triggering the upgrade e.g. for the CNF Upgrade timeout set the global parameter in TCA CP with below mentioned API Call.
    PUT https://<TCA_CP>/admin/hybridity/api/global/settings/<namespace>/<option>
  2. For details on the API Call and parameter options refer to the TCA documentation below 
    TCA CP Upgrade Timeout API Call Settings