ConnectALL Upgrade terminates with error "Database server is not running. Please start the server and proceed the install"
book
Article ID: 409107
calendar_today
Updated On:
Products
ConnectAll On-PremConnectALL
Issue/Introduction
When attempting to run upgrade from ConnectALL 3.6 to 3.9 with MSSQL database using windows authentication, upgrade terminates with error below.
Environment
3.x
Cause
You will see the installer logs generated in C:/users/user/AppData/local/temp location are pointing to DB connection failure as installer will attempt to connect DB using the user used to run the installer and fail with error below.
[ERROR] com.install4j.runtime.beans.screens.FormScreen [ID 44767]: com.microsoft.sqlserver.jdbc.SQLServerException: Login failed for user 'DOMAIN\user'. ClientConnectionId:b54887a7-de14-41d5-958b-68c174b4fff2
In screen [ID 21730], property "Condition expression":
com.microsoft.sqlserver.jdbc.SQLServerException: Login failed for user 'DOMAIN\user'. ClientConnectionId:b54887a7-de14-41d5-958b-68c174b4fff2
at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:262)
at com.microsoft.sqlserver.jdbc.TDSTokenHandler.onEOF(tdsparser.java:283)
Resolution
Run the installer with Service account used for MSSQL windows authentication for ConnectALL.