After ESXi was reinstalled datastores are missing/no longer presented to the host.
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After ESXi was reinstalled datastores are missing/no longer presented to the host.

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Article ID: 409088

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

After reinstall of ESXi, IQN of ISCSI software adapter changed, as such the ESXi host can no longer access the storage array. 

Environment

VMware ESXi (All Versions)

Cause

After reinstalling ESXi, the host is assigned a new iSCSI Qualified Name (IQN), which is why it can no longer access the storage array. This breaks the SAN-level permissions, which were configured to allow the old IQN to access the LUNs presented from the storage array .

Resolution

Option 1: Configure the ESXi host with the original IQN

This method is recommended if multiple ESXi hosts accessing the same storage. It avoids having to make changes on the SAN.
  1. Locate the old IQN(can normaly be found on the allowed list on the storage array)
  2. Log in to the ESXi Host Client and navigate to Storage > Adapters.
  3. Select the iSCSI Software Adapter and click Configure iSCSI.
  4. Edit the iSCSI Name field to enter the old IQN, then click Save configuration.
  5. Perform a Rescan:
    • Navigate back to the Storage Adapters view.
    • Click Rescan, and select both "Rescan for new storage adapters" and "Rescan for new storage devices."
    • Check the Datastores tab to see if your storage is now visible. 

Option 2: Update SAN permissions with the new IQN

If the old IQN is not available, update your storage array (SAN) to accept the new one.
  1. Retrieve the new IQN:
    • In the ESXi Host Client, navigate to Storage > Adapters.
    • Select the iSCSI Software Adapter and copy the iSCSI Name.
  2. Access the SAN management interface. This will vary depending on the storage vendor (e.g., Dell, NetApp).
  3. Locate the host access settings for the LUNs that the host needs to access. This is often in the "Host Access," "Initiators," or "Mappings" section.
  4. Add the new IQN to the list of allowed initiators for the relevant storage volumes.
  5. Rescan Storage on the ESXi host:
    • Return to the ESXi Host Client.
    • Go to Storage > Adapters, click Rescan, and perform a full rescan

If all volumes/LUNs/datastores are not presented to the Host after the rescan, reboot the host and reverify. 

 

If you have any additional questions, or concerns regarding this issue please open a case with VMware Support for further investigation.