Service Offering 'Permissions' do not get saved properly
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Service Offering 'Permissions' do not get saved properly

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Article ID: 40892

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Updated On:

Products

CA Service Catalog

Issue/Introduction

For a CA Service Catalog Offering, the 'Permissions' do not get saved properly. 

The following errors are seen in the CA Service Catalog view.log:

Insert Error: PozError, PE_NOTFOUND Object Not Found. 

[Insert Error: PozError, Insert Error: PozError, PE_NOTFOUND Object Not Found, /iTechPoz/Store/Service Catalog/custom/Policies/ACL_10183_Offerings,

PozObject.insert: error invoking iPoz::ObjectInsert, Object create failed, ISE_NOSUCHOBJECT no such object exists]\

Environment

CA Service Catalog 14.x and 17.x

All Supported Operating Systems

Cause

Basically, CA Service Catalog is trying to insert the permission on /iTechPoz/Store/Service Catalog/custom/Policies location.

Which does actually/appears not to exist in the EEM internal folder structure.

Cause of the error: the "Policies" folder was missing

 

Resolution

How to confirm:

1. Login to the EEM UI with Application ID "Service Catalog"

2. Navigate to Configure and check the "Folders" link.

3a. In this folder tree view you can find the folder named "custom"

3b. Which should hold the folder "Policies"

Resolve this by adding the "Policies" folder:

5. Click on/select the "custom" folder-icon

6. Click on the folder-icon in front of the "custom" folder ("New Application Folder")

7. Enter the folder name "Policies" (with capital P)

8. Click on 'Save" and "Refresh"(in the folder tree pane)

Now you should be good to save the permissions of a CA Service Catalog offering properly.