Site pairing is failing on SRM instances with error "Unable to connect to Site Recovery Manager Server"
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Site pairing is failing on SRM instances with error "Unable to connect to Site Recovery Manager Server"

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Article ID: 408851

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Site pairing is failing with below errors on site recovery manager UI.

SRM server '####' cannot complete a pair operation. Failed to look up the host name '#####' in DNS.

 
 
  • Certificate details may not populate on SRM VAMI page and may report below errors:

https://<SRM-IP>:5480  >> Certificates

Failed to look up the host name '#####' in DNS.

  • /var/log/vmware/drconfigui/drconfigui.log on SRM appliance report below errors:

2025-08-26T04:34:44.224Z warning drconfig[01054] [SRM@6876 sub=IO.Connection opID=########-####-####-####-############-getCertificateInfo] Failed to resolve address; <resolver p:0x0000##############, 'SRM#:443', next:(null)>, e: 1(Host not found (authoritative)), async: true, duration: 9msec
2025-08-26T04:34:44.2242 error drconfig[01054] [SRM@6876 sub=ProbeSs1.Url.DrConfigSslCertificateManager opID=########-####-####-####-############-getCertificateInfo] Failed to connect a TCP socket to 'SRM#:443'
-- > N7Vmacore15SystemExceptionE Host not found (authoritative): The connection was closed by the remote end during handshake. (1)

Environment

VMware vCenter Server 8.x
Site Recovery Manager 8.x
VMware Live Site Recovery 9.x

Cause

SRM site pairing failed because "short hostname" was configured on the SRM appliance instead of the "Fully Qualified Domain Name (FQDN)".

Resolution

Update the SRM appliance’s network settings with correct FQDN instead short host name.

Steps to follow:

  1. Log in to the VAMI of the SRM via  https://<SRM-IP>:5480

  2. Navigate to Summary and verify the Hostname and vCenter Server details.

  3. Go to Networking and check if the Hostname is correctly updated or if it is using a short FQDN.
    • If incorrect, click Edit and update it with the correct FQDN.

     4. Reconfigure the appliance.

     5.Once reconfiguration is complete, the connection to the SRM server will be established.