Applying a license to an ESX host succeeds but the license is not applied
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Applying a license to an ESX host succeeds but the license is not applied

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Article ID: 408845

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

When applying a new license to an ESX host, the license is validated and then applied but no changes occur in the Licensing page to reflect the change.

The tasks panel shows:

  • Decode License: Completed Successfully
  • Update License Result: Completed Successfully

No errors are seen in vpxa.log or hostd.log for the replacement of the license.

Environment

VMware vSphere ESXi 8.x

VMware vSphere ESXi 7.x

Cause

Though the license key decodes properly and can be applied, the key is corrupt.

Resolution

You will need to replace the license that was generated.  To do so, create a GCA support case to have a replacement license provided:  https://knowledge.broadcom.com/external/article/142884/creating-and-managing-broadcom-support-c.html