Jobs are not visible or disappeared from apps in Apps Manager
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Jobs are not visible or disappeared from apps in Apps Manager

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Article ID: 408834

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Updated On:

Products

VMware Tanzu Platform - Cloud Foundry

Issue/Introduction

Jobs are not visible or disappeared from apps in Apps Manager. It may show "No tasks are currently scheduled."

Example:

 

The cf jobs command returns an error: "You must create an instance of the scheduler service in this space to use the scheduler service."

~ % cf jobs
Listing jobs for org test / space test as admin
FAILED

  You must create an instance of the scheduler service in this space to use the scheduler service.

 

The cf services command shows that there is an instance of the scheduler service already created:

~ % cf services
Getting service instances in org test / space test as admin...

name           offering            plan       bound apps   last operation     broker              upgrade available
my-scheduler   scheduler-for-pcf   standard   test-app   create succeeded   scheduler-for-pcf   no

Environment

Tanzu Platform Cloud Foundry and Scheduler for Tanzu

Cause

This issue can happen when the scheduler broker is down

Resolution

Check the status of the scheduler:

  1. cf target -o system -s scheduler
  2. cf apps

Example:

~ % cf target -o system -s scheduler
API endpoint:   https://api.example.com
API version:    3.199.0
user:           admin
org:            system
space:          scheduler

~ % cf apps
Getting apps in org system / space scheduler as admin...

name               requested state   processes           routes
scheduler          started           web:3/3, task:0/0   scheduler.example.com
scheduler-broker   stopped           web:0/3             scheduler.example.com/v2

In this example, the scheduler-broker is stopped and needs to be started (cf start scheduler-broker)

If the app is crashed or anything other than "started" then check the app logs (cf logs scheduler-broker --recent) and troubleshoot the reason for the crash. These Troubleshooting Commands are a good place to start.

Once the apps in the scheduler space are up and running the issue should be resolved