Scheduled file-based backups are failing in vCenter Server Appliance.
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Scheduled file-based backups are failing in vCenter Server Appliance.

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Article ID: 408833

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Scheduled file-based backups are failing in vCenter Server Appliance.

  • Manual (on-demand) backups complete successfully without any issues.

  • Log file on VC /var/log/vmware/applmgmt/backupScheduler.log shows error message referencing incorrect credentials:

YYYY-MM-DDThh:mm:ss [0] [MainProcess:PID-3736980] [Scheduler::ExecArchiveList:Scheduler.py:119] ERROR: Failed to issue the Archive.list request. Exception: {messages : [LocalizableMessage(id='com.vmware.applmgmt.backup.plugin.unauthorized', default_message='Access to the backup server is denied. Check your credentials.', args=['Plugin error occurred. ErrCode: 1, Args: ()'], params=None, localized=None)], data : None, error_type : None}
Traceback (most recent call last):
  File "/usr/lib/applmgmt/backup_restore/py/vmware/appliance/backup_restore/Scheduler.py", line 116, in ExecArchiveList
    backupList = svc_handle.list(locationSpec, systemName, filterSpec)
  File "/usr/lib/applmgmt/pyclient/applmgmt_client-1.0-py2.7.egg/com/vmware/appliance/recovery/backup/system_name_client.py", line 289, in list
    return self._invoke('list',
  File "/usr/lib/applmgmt/vapi/lib/vapi_runtime-2.100.0-py2.py3-none-any.whl/vmware/vapi/bindings/stub.py", line 345, in _invoke
    return self._api_interface.native_invoke(ctx, _method_name, kwargs)
  File "/usr/lib/applmgmt/vapi/lib/vapi_runtime-2.100.0-py2.py3-none-any.whl/vmware/vapi/bindings/stub.py", line 295, in native_invoke
    raise TypeConverter.convert_to_python(method_result.error,  # pylint: disable=E0702
com.vmware.vapi.std.errors_client.Error: {messages : [LocalizableMessage(id='com.vmware.applmgmt.backup.plugin.unauthorized', default_message='Access to the backup server is denied. Check your credentials.', args=['Plugin error occurred. ErrCode: 1, Args: ()'], params=None, localized=None)], data : None, error_type : None}

Environment

vCenter Server 8.x
vCenter Server 7.x

Cause

The issue occurs when backup server password configured in VAMI is either incorrect or has expired.

Resolution

  • Log in to the VAMI of the vCenter Server Appliance using:
https://<VCSA-FQDN-or-IP>:5480
  • Navigate to Backup > Configure.

  • Update backup server credentials with correct password and save the configuration.

Note: Ensure that the backup server is reachable over the network and that the account has required permissions to write to backup location.

Additional Information