Receiving error Access Denied Access denied. Unable to authenticate the user when logging into vCenter with Entra ID account that was configured through VIDB
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Receiving error Access Denied Access denied. Unable to authenticate the user when logging into vCenter with Entra ID account that was configured through VIDB

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Article ID: 408820

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Updated On:

Products

VCF Operations

Issue/Introduction

Environment

VCF 9.0 Identity Broker

Cause

Unique Identifier in OIDC Identity Provider was set to use email while scim push ExternalId attribute was mapped to objectId(oid).  This results in login failure.    

Resolution

 Update the "Unique Identifier in OIDC Identity Provider" to oid as EntraId provides objectid in oid claim in the id token.