High percentage at "pNIC vSwitch Port Drop Rate" in VSAN Performance stats under Physical Adapter tab when there is no traffic on that vmnic
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High percentage at "pNIC vSwitch Port Drop Rate" in VSAN Performance stats under Physical Adapter tab when there is no traffic on that vmnic

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Article ID: 408796

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Updated On:

Products

VMware vSphere ESXi VMware vSAN

Issue/Introduction

  • High number of percentage drops detected at  "pNIC vSwitch Port Drop Rate" on the vmnic that is very little or not utilized by vmk or VM network traffic, like in the following screenshot:



  • When there is significant traffic seen in Monitoring > VSAN > Performance > Physical Adapter > "pNIC Packets Per Second" counter on the vmnic in question, the drops rate is practically at 0%

Environment

VMware vSAN 8.x

Cause

  • "pNIC vSwitch Port Drop Rate" checks the vSwitch stats, which can include valid drops, for example if the physical switch sends a packet that can't be delivered (such as multicast or unknown unicast).  If a vmnic is not being utilized, the drop percentage calculated from all traffic being forwarded to the vmnic may appear high.

  • When the vmnic is being utilized and more traffic is being received, the percentage "pNIC vSwitch Port Drop Rate" would drop near 0% even if the same number of packet drops are still occurring.

Resolution

This is an expected behavior if there is no VM/vmk traffic on the vmnic in question.

Additional Information

As per vSAN Performance Graphs in the vSphere Web Client Part 1 :

pNIC vSwitch Port Drop Rate

This graph shows percentage of Physical NIC vSwitch Port Drop Rate.

Metrics Metrics Description Metric ID in API Corresponding Entity Type Corresponding Real-time Entity type
Inbound Packet Drop Rate of pNic vSwitch Port Percentage of Physical NIC Inbound vSwitch Port Drop Rate. portRxDrops vsan-pnic-net hr-vsan-pnic-net
Outbound Packet Drop Rate of pNic vSwitch Port Percentage of Physical NIC Outbound vSwitch Port Drop Rate. portTxDrops vsan-pnic-net hr-vsan-pnic-net

 

Q: Would setting the uplinks for the vSAN vmkernel adapter to Active/Standby help mitigate this alert?

A: Keeping the uplink in an Active/Standby or Active/Active configuration makes no difference. This is because the pNic error health check monitors all the uplinks configured for the vSAN vmkernel's port group.