vCenter root account showing disconnected in VCF Operations Manager UI
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vCenter root account showing disconnected in VCF Operations Manager UI

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Article ID: 408771

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Updated On:

Products

VMware SDDC Manager VCF Operations

Issue/Introduction

  • When viewing Fleet Manager > Password > VCF Management within VMware Cloud Foundation (VCF) Operations Manager, the root account for the vCenter server appliance displays a status of Disconnected
  • Alert in a vCenter after resetting a root password directly from the vCenter: "[1] account(s) has been disconnected. Visit Password Management page to take action."

Environment

VMware Cloud Foundation Operations 9.x
vCenter Server 9.x

Cause

This issue occurs when the root password for the vCenter server appliance operating system has expired.

Resolution

To resolve this issue, reset the expired root password on the vCenter server appliance and then remediate the password within the Operations Manager UI.

Steps to follow:

  1. Take a snapshot of the vCenter
  2. Gather the vCenter old root password from the SDDC manager UI:
    Go to the Developer Center >Credentials >Get (Retrieve a list of credentials)
    Enter a value VCENTER in resourceType and EXECUTE
  3. Reset the vCenter's root password with its old password:
    a. SSH into the vCenter with root user using the new password
    b. Clear the password history with the following command:
        cat /dev/null > /etc/security/opasswd
    c. Reset the root vCenter's root password with the old password:
      passwd root 
  4. SSH into the SDDC Manager with vcf user and su to root
    Run the following command to get password failed workflow IDs:
    psql -h localhost -U postgres -d operationsmanager -c "select workflow_id, operation_type, transaction_status from passwordmanager.password_operations where transaction_status='FAILED' OR transaction_status='PREVALIDATION_FAILED';"
    Note:
    If there are some IDs, move to a step 5.
    If not, move to a step 6.
  5. Delete the failed workflow ID from the Developer Center >Credentials >DELETE (cancel a failed credential task by its ID) and delete them by entering each ID, then EXECUTE.
  6. From the VCF Operation, go to Fleet Management >Passwords >VCF instances >vCenter and remediate the root password.

Additional Information

Since the system performs password validation checks periodically, it may take anywhere from 1 to 24 hours for the account status to visibly update to Active (green) in the UI after a successful remediation.