SDDC Manager password remediation fails for vRealize log Insight (vRLI)
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SDDC Manager password remediation fails for vRealize log Insight (vRLI)

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Article ID: 408426

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

SDDC Manager is unable to remediate passwords for vRealize Log Insight (vRLI), resulting in inventory and password synchronization issues.

When reviewing the task details in SDDC Manager, the following error message is seen:

Error
Password remediate for resource: localhost, user: root and credential type: SSH Testing existing ssh credential for the entity: localhost has failed.
Message: Testing existing ssh credential for the entity: localhost has failed.
Remediation Message: Please verify that the account is active and is not locked. If the password of the account has expired, manually reset the password in the product and then perform a REMEDIATE operation in the SDDC Manager, to update its stored copy of the password. Reference Token: XXXXXX

Cause: Failed to execute command, error: SSH: Failed to establish SSH session to localhost

Environment

  • VMware Cloud Foundation
  • VMware SDDC Manager
  • VMware vRealize Log Insight (vRLI)

Cause

The issue occurs when the vRLI appliance's hostname is configured as 'localhost', preventing SDDC Manager from properly managing passwords and inventory.

Resolution

To resolve the issue, follow these steps:

1.Update the hostname of the vRLI appliance to a unique name by referring to the article "Hostname configurations in VMware Aria Operations for Logs 8.14+".

2.Perform an inventory resync in SDDC Manager by following the steps in the article "Synchronize inventory versions after out-of-band upgrade in a VMware Cloud Foundation Environment".

3.Trigger an inventory sync in LCM by referring to the article on Inventory synchronization in VMware Aria Suite Lifecycle.