Some Package Servers are partially downloading a few packages
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Some Package Servers are partially downloading a few packages

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Article ID: 408409

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

You captured an initial deployment disk image on one of your site package servers. Some of the package servers have successfully been able to download the appropriate disk image files (under the Cache folder), the snapshot.xml, and the snapdata.xml files:

There are at least two package servers that have no content in the Cache folder, and the snapshot.xml and the snapdata.xml files do not match the package servers that were successful in downloading the packages:

Note: This issue may occur with other type of packages besides deployment disk image files.

Environment

ITMS 8.x.x

Cause

Unknown. This was likely a timing issue when the initial package reference was received and the actual hosting package server didn't have the files yet.

Resolution

The following steps are provided as a guidance of what to do in case resetting the affected package doesn't work (resetting means: making some sort of change to it to force to be seen as a new version and force download) or even restarting the package server services didn't make a difference.

For this example, the affected package will be called "Windows 10 LTSC 2021 0625 OTR".
The affected example package GUID is: 5E9233CB-032A-47A8-821C-B1A81D5DDD47

1. Try to add a dummy txt file to the affected package (to force it to be considered a new package version) and see if the issue still persists.

2. Make sure that the database has the right package version. Check that SWDPackage, SWDPackageCodebase, SWDPackageServer tables to verify if they have the right entries, especially the package version. This SQL query will help:

select * from SWDPackage
where packageid = '5E9233CB-032A-47A8-821C-B1A81D5DDD47'  --GUID of affected package

select * from SWDPackageCodebase
where packageid = '5E9233CB-032A-47A8-821C-B1A81D5DDD47'

select * from SWDPackageServer
where packageid = '5E9233CB-032A-47A8-821C-B1A81D5DDD47'

3. Clean up the package reference from the agent Secure Storage on your Package Server by doing the following:

a) In order to delete the package information from the Secure Storage, you'll need to be able to access the Secure Storage. For that you'll need to create and enable "Remote Troubleshooting Password" from within the SMP console:

i. In SMP console access Settings->Agents/Plug-ins->Symantec Management Agent->Settings->Global Agent Settings

ii. Place checkmark on "Allow remote troubleshooting" and input password of your choice and click Save

iii. Update agent configuration on the package server to receive the "remote troubleshooting" password. 

b) Copy the SMATool.exe from the SMP server to the package server, as well as Microsoft's PsExec:

i. Locate SMATool (...\Program Files\Altiris\Notification Server\Bin\Tools) and copy it to where your PsExec tool located on the package server.

ii. Start CMD with Admin privileges and navigate to PsExec tool directory

iii. Start PsExec via the following command "psexec -i -s cmd.exe". A new CMD will open running under "nt authority\system" account (to check this is working type the "whoami" command). Go to the Properties of new CMD and in Layout tab modify the Screen buffer size Height to higher number (9999) to see all of the screen output

iv. Navigate to the same directory as the PsExec tool and SMATool and issue the following commands:

            a) "net stop aexnsclientto stop Symantec Management Agent service to unlock locking handles from the Secure Storage to be able to make necessary modifications

            b) "iisreset /stop" to stop IIS service

            c) delete the package reference from the "Software Delivery" and "Package Delivery" folders in the Secure Storage with the following command:

Smatool.exe /storage delete  "Software Delivery\{5E9233CB-032A-47A8-821C-B1A81D5DDD47}"
Smatool.exe /storage delete  "Package Delivery\{5E9233CB-032A-47A8-821C-B1A81D5DDD47}"  

             d) You should be prompted for the "Remote troubleshooting password". Type it and click Enter.       

Note: Deleting a specific package entry from the Software Delivery and Package Delivery repository in the Secure Storage will not remove files from the "...\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery" and "...\Program Files\Altiris\Altiris Agent\Package Delivery" directories. It will only remove information about those packages from the SMP.

  e) Delete all .xml files for the {5E9233CB-032A-47A8-821C-B1A81D5DDD47} directory. While in the psexec window that you opened to run smatool.exe, navigate to "Program Files\Altiris\Altiris Agent\Package Delivery\{5E9233CB-032A-47A8-821C-B1A81D5DDD47}" and from inside of that directory run the following:
                         
                   del snapshot.xml
         del snapdata.xml
         del log.xml 
         
rmdir cache

f) Delete the {5E9233CB-032A-47A8-821C-B1A81D5DDD47} folder now that it is empty. While in the psexec window that you opened to run the smatool.exe tool, navigate to "Program Files\Altiris\Altiris Agent\Package Delivery" and from inside this directory run the following:
                         
                   rmdir {5E9233CB-032A-47A8-821C-B1A81D5DDD47}

  g)  net start aexnsclient - to start SMA service back
  h) iisreset /start - to start IIS

4. Now open the Symantec Management Agent (SMA) UI window on your package server and manually request "Update Configuration". In the "Package Server" tab, click on the "Refresh All Packages" link and after it is done, Click both "Check integrity" and "Resend status" for the affected package and after a few minutes you should see the package retrying to download. Make sure the package actually is ready on the package server where this package should be downloading from:

5. Then navigate back to the SMP console and disable "Allow remote troubleshooting":

 

Additional Information