all users unable to log in to DX UIM
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all users unable to log in to DX UIM

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Article ID: 408359

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Symptoms:

  • all users are unable to log in to Infrastructure Manager, Operator Console, or Admin Console
  • one user was prompted to change their password but others are unable to log in at all
  • DX UIM CU4 or higher was applied approximately 90 days prior 

 

Environment

  • DX UIM 23.4.4 (23.4 CU4) or higher
  • this issue is likely to occur on the 90th or 91st day after the upgrade to CU4 or higher

Cause

  • After upgrading to CU4 or higher, a new password policy is implemented which includes a default expiration time of 90 days
  • this expiration time starts counting down the first time the user logs in after the upgrade and resets when the user changes their password
  • the user who was prompted to change their password was logging in to Admin Console and was prompted to change their password there since it had expired
  • remaining users logging into Infrastructure Manager were not prompted to change their expired passwords because they were running IM 24.3.3 which does not prompt, it fails the login

Resolution

  • the user who was initially prompted to change their password can log in with their new password and temporarily disable password expiration.  After this, other users should be able to log in with their old passwords.
  • otherwise, users who have access to Admin Console can try logging in with their old passwords and they should be prompted to change their passwords at that time
  • additionally, upgrading all Infrastructure Manager client instances on remote laptops/workstations to 23.4.4 will allow the users to try logging in with their old passwords and they should be prompted to change their passwords at that time.

Additional Information