Identity Portal fails to start after switch database
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Identity Portal fails to start after switch database

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Article ID: 408328

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Updated On:

Products

CA Identity Manager

Issue/Introduction

After switching the database instance while the Identity Portal was connected through DB cluster, the Identity Portal failed to deploy

 

Environment

Identity Portal 14.5.1

Cause

The database instance switch has a latency that causes the Identity Portal connection timeout

Resolution

Modify standalone.xml and adding the following under the Identity Portal datasource section then restart Identity Portal

<validation>
                        <check-valid-connection-sql>select 1</check-valid-connection-sql>
                        <validate-on-match>false</validate-on-match>
                        <background-validation>true</background-validation>
                        <background-validation-millis>120000</background-validation-millis>
                        <use-fast-fail>false</use-fast-fail>
</validation>