Alarm filters are locked by another user and cannot be unlocked.
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Alarm filters are locked by another user and cannot be unlocked.

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Article ID: 408307

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Updated On:

Products

Network Observability

Issue/Introduction

We are facing the issue that one of our alarm filter is locked by an already deleted user (non existent in spectrum).  
We already tried to unlock it, then it which seems on the first view successfull, but changes in the alarm filter are not saved.  If we are changing the tab and get back to the alarm filter page the filter is again been locked by this user.

Cause

We were unable to recreate, insofar as an admin could unlock the preferences for any other user existing or deleted.

Resolution

There are 2 different ways to approach resolving this. 

A.  import the preferences from another user that has no alarm filters set, to overwrite the currentlly locked filters.

or

B. Manipulate the attribute 0x129ef of the model corresponding to user in question, in CLI or via REST to remove the filters.

 

Additional Information

Via CLI we would pull the preferences as follows

./connect

./show attributes attr=0x129ef mh=<model handle of user>

The attribute value has an XML format that can be manipulated manually to remove the filters and then updated on the user.