Alert “One or more monitored service(s) are unavailable on the virtual machine” is not triggered for vCenter VM in Aria Operations
search cancel

Alert “One or more monitored service(s) are unavailable on the virtual machine” is not triggered for vCenter VM in Aria Operations

book

Article ID: 408256

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Service Discovery is enabled on the vCenter VM; however, the alert “One or more monitored service(s) are unavailable on the virtual machine” is not triggered for the vCenter VM.
  • When enabling Service Discovery on the vCenter VM, the VMware vCenter (appliance) services, including vpxd, is expected to be monitored. Despite this, the alert does not appear when the vpxd service is down.

Environment

VMware Aria Operations 8.x

Cause

When the vpxd service is down, Aria Operations is unable to collect data from the vCenter instance. As a result, the service status is not captured, and the alert is not triggered.

Resolution

This is an expected behavior. When the vpxd service is down, data collection itself stops, so the alert “One or more monitored service(s) are unavailable on the virtual machine” will not be generated for the vCenter VM.

Workaround:
To capture such scenarios, place the vCenter VM under the management of a different vCenter. In this setup, if the vpxd service crashes, Aria Operations will be able to detect the service crash and trigger the alert accordingly.