LDAP sign-in option missing from VMware Cloud Director provider portal
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LDAP sign-in option missing from VMware Cloud Director provider portal

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Article ID: 408245

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • LDAP is set up and users have been successfully imported with system administrator privileges, but there's no visible option on the login page to authenticate with LDAP credentials.



  • When attempting to login to VMware Cloud Director provider portal, with ‘domain\user’ or <[email protected]>, it fails with an 'Authentication Error'.

Environment

VMware Cloud Director 10.6.x

Cause

The system is configured to allow both local and imported LDAP users to authenticate transparently by default, without requiring domain prefixes or suffixes.

Resolution

After integrating LDAP from the provider portal and importing users with the system administrator role, users can log in directly using their username and password, eliminating the need for domain prefixes or suffixes. Once identity providers such as SAML or OIDC are configured, users are provided with following sign on options:

‘Sign in with SAML’ , 'Sign in with LDAP' and ‘Sign in with local account’.

Additional Information