Horizon UI not accessible via public VIP
search cancel

Horizon UI not accessible via public VIP

book

Article ID: 408201

calendar_today

Updated On:

Products

VMware Integrated OpenStack

Issue/Introduction

  • Horizon is supposed to be on Public VIP but will randomly switch over to another address
  • Ingress pods had diskpressure issues

Environment

7.x

Cause

The address that is accessible is eth1 on one of the controller nodes.  That node must have one of the two ingress pods running on it which forward requests to the Horizon pods.  The Horizon UI can be opened on this IP.  Since there are 3 controllers in a standard HA deployment and only 2 ingress pods, there is one controller which does not have an ingress pod running on it.  The eth1 IP address of that controller won't be able to open the Horizon UI.  

Normally the public VIP is bound to one of the controllers by one of the two ingress pods.  If the the VIP is not accessible/responsive, there might be a problem with one or both of the ingress pods and the requests not being forwarded.

 

Resolution

  1. Check the status of the ingress pods to determine cause of the problem.
    #osctl describe pod <pod name>
  2. The ingress pods might be having issues due to DiskPressure issues.  If that is the case, determine the cause of the DiskPressure issue. 
  3. Increasing the size of the controller nodes can alleviate the space issue as well.  See Extending root disk of VIO controllers