VS unable to place on SE with error "Reached configured maximum limit"
search cancel

VS unable to place on SE with error "Reached configured maximum limit"

book

Article ID: 408166

calendar_today

Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

  • When attempting to place a Virtual Service (VS) on a Service Engine (SE), the following error is displayed "Reached configured maximum limit of X Service Engines in Service Engine group SEG_NAME"
  • This error indicates that the maximum limit for Virtual Services (VS) per Service Engine has been reached within the configured Service Engine Group (SEG).

Environment

VMware

Cause

Each Service Engine Group (SEG) has a parameter called Virtual Services per Service Engine.
When the number of Virtual Services placed on a Service Engine exceeds this configured limit, the system prevents placement of additional VSs and triggers this error message.

Resolution

There are multiple ways to resolve this issue:

Option 1: Increase the Virtual Services per Service Engine

  • Edit the Service Engine Group configuration.
  • "Virtual Services per Service Engine" limit to accommodate more Virtual Services on each SE.
  • Disable and Re-enable the VS 

Option 2: Increase the Number of Service Engines in the SEG

  • Increasing the "Number of Service Engines" in the SEG.
  • Disable and Re-enable the VS 
  • The system will create a new Service engine and place the VS on the newly created Service Engine.