Error: "You don't have permissions to access the HCX system or too many active sessions. Try again after sometime" when loading the HCX plugin from the vSphere Client
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Error: "You don't have permissions to access the HCX system or too many active sessions. Try again after sometime" when loading the HCX plugin from the vSphere Client

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Article ID: 408161

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • After upgrading to vCenter 8, loading the HCX plugin from the vSphere Client presents the following error:

    You don't have permissions to access the HCX system or too many active sessions. Try again after sometime.

  • In the HCX manager appliance when checking the /common/logs/admin/web.log for /hybridity/ap/sessions, you see the following errors referencing SYSTEM-DOMAIN.



  • When reviewing the domains available in SSO, both SYSTEM-DOMAIN and vsphere.local are present.

Environment

vCenter 8

Cause

This is due to a leftover artifact in SSO on vCenter during the migration from legacy SSO (SYSTEM-DOMAIN:vSphere 5.1) to modern SSO (vsphere.local: vSphere 5.5 and above).

Resolution

If it is found that the environment has both SYSTEM-DOMAIN and vsphere.local, open a support request with Broadcom to fix the issue.