SRM recovery fails with an error "Invalid configuration for device '0'"
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SRM recovery fails with an error "Invalid configuration for device '0'"

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Article ID: 408132

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Running test recovery on a SRM recovery plan fails with an error for some VM's  "Invalid configuration for device '0'" 




  • In the  vmware-dr.log of the vSphere Replication Appliance these messages are logged indicating failure while configuring network on the VM:
error vmware-dr[01386] [SRM@6876 sub=Replication.VmRecoveryInterface ctxID=a2d5fee0 opID=3904f142-####-####-a47b-d6e7441#####-test:3191:e1ae:4a9d] Protection VM 'dr.replication.ProtectedVm:protected-vm-XXXXX' failed operation 'StartTest'!  There are '0' warnings for this Protection Group.  Failure Reason: (vim.fault.InvalidDeviceSpec) {
error vmware-dr[211039] [SRM@6876 sub=Recovery ctxID=503a83f8 opID=3904f142-####-4985-####-d6e7441#####-test:3191:e1ae:4a9d] [262b1026-6574-4dcb-8376-a661034ef455.failoverOrchJob] Replication reported failure for VM "VM Name" [null], the vm will not be recovered: (vim.fault.InvalidDeviceSpec) {

error vmware-dr[01495] [SRM@6876 sub=Recovery ctxID=503a83f8 opID=3904f142-####-####-a47b-d6e7441#####-test:3191:e1ae] [failoverMain] There were errors during recovery of vms, first failure: (vim.fault.InvalidDeviceSpec) {
verbose vmware-dr[01495] [SRM@6876 sub=Default ctxID=503a83f8 opID=3904f142-####-####-a47b-d6e7441#####-test:3191:e1ae] [failoverMain] Setting job failure: (vim.fault.InvalidDeviceSpec) {
error vmware-dr[211050] [SRM@6876 sub=Recovery ctxID=503a83f8 opID=3904f142-####-####-a47b-d6e7441#####-test:3191:e1ae] [failoverMain] Execution failed: (vim.fault.InvalidDeviceSpec) {
-->       (vim.fault.InvalidDeviceSpec) {
-->       (vim.fault.InvalidDeviceSpec) {
error vmware-dr[211062] [SRM@6876 sub=Recovery ctxID=503a83f8 opID=3904f142-####-####-a47b-d6e7441#####-test:3191] Plan execution (test workflow) failed; plan id: 262b1026-####-4dcb-####-a661034ef455, plan name: "PG Name",

error vmware-dr[211062] [SRM@6876 sub=Recovery ctxID=503a83f8 opID=3904f142-####-####-a47b-d6e7441#####-test:3191] Plan 'PG_Name' failed: (vim.fault.InvalidDeviceSpec) {
--> (vim.fault.InvalidDeviceSpec) {
  • In the  vmware-dr.log of the vSphere Replication Appliance at the DR site similar logging to the below may be seen: 
verbose vmware-dr[ID] [SRM@ID sub=PlaceholderVmManager opID=OP-ID] [PlaceholderVm] Finding compatible host for swapping placeholder VM '[vim.VirtualMachine:VM-ID]', which is currently on host '[vim.HostSystem:HOST-ID]'

verbose vmware-dr[ID] [SRM@ID sub=LocalSite.LocalVcServer.NetworkLocator opID=OP-ID] Found DVS Portgroup with switchId 'SWITCH-ID' and portKey 'dvportgroup-ID' related to network 'vim.dvs.DistributedVirtualPortgroup:PORTGROUP-ID'.

verbose vmware-dr[ID] [SRM@ID sub=HbrProvider opID=OP-ID] Found network card '4000' backed by vDS portgroup 'dvportgroup-ID @ SWITCH-ID'
verbose vmware-dr[ID] [SRM@ID sub=HbrProvider opID=OP-ID] Fixing backing of network card 4000 to 'dvportgroup-ID @ SWITCH-ID'error
info vmware-dr[ID] [SRM@ID sub=DeviceGroupManager.DeviceFetcherPropertyQueue opID=OP-ID] Starting task 'Task-ID' from queue 'TaskQueue-ID' at: FetchDevices(678)

error vmware-dr[ID] [SRM@ID sub=RemoteTask.task-ID opID=OP-ID tid=task-ID.VirtualMachineReconfigure] The remote task 'vim.Task:TASK-ID' failed:
--> (vim.fault.InvalidDeviceSpec) {
--> faultCause = (vmodl.MethodFault) null,
--> faultMessage = ,
--> property = "virtualDeviceSpec.device.backing",
--> deviceIndex = 0
--> msg = "Invalid configuration for device '0'."

Identify the host friendly from the [vim.HostSystem:HOST-ID] :

identify host MOD in vcenter MOB
https://vc-address/mob/?moid=vim.HostSystem:HOST-ID
authenticate with either SSO-admin/domain user account

 

Environment

VMware Site Recovery Manager 8.X
VMware Live Site Recovery 9.x

Cause

  • The issue is caused by incorrect port group or no port group assigned to be VM to be recovered on recovery site.
  • Physical host at the DR site may not have correct mapping to the required port group on the VDS.

Resolution

  • The network port group to be used by recovery VM needs to be validated on recovery site and make sure port groups are mapped properly in the SRM network mapping for the protected VM's.
  • Ensure the host is attached to the VDS associated with the port group. If the error persists, try removing and re-adding the host to the VDS to refresh the port groups. As a final resort, delete and recreate the port group, then re-map it in SRM