Newly deployed Policy Server stops working after a while when using SmLimitAuth module
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Newly deployed Policy Server stops working after a while when using SmLimitAuth module

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Article ID: 408093

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Updated On:

Products

SITEMINDER

Issue/Introduction

New Policy Server is setup with SmLimitAuth module.

After a while the Policy Server rejects authentication and logs the following error in the smps.log

************************************************************
**        Evaluation of SmLimitAuth has timed out         **
**          Server must be restarted to continue          **
************************************************************

[No license, quitting.][SmLimitAuth: No license, quitting.]

Cause

SmLimitAuth requires a license file to operate.

If the "{siteminder}/license/NPSLicense.txt" license file is not found then the module will run in trial mode and will operate for 2 hours then stops working until restart.

Resolution

Place the NPSLicense.txt license file in the new Policy Server license folder and restart Policy Server.