VMware Aria Suite Lifecycle Patch 3 or Patch 5 Installation appears stuck or hangs indefinitely
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VMware Aria Suite Lifecycle Patch 3 or Patch 5 Installation appears stuck or hangs indefinitely

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Article ID: 408026

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • You are attempting to install new patch for Aria Suite Lifecycle.
  • Patch install task for Aria Suite Lifecycle 8.18 Patch 3 or 5 appears stuck with a Request Status of In Progress.

  • The appliance has fully rebooted and reporting the latest version you just applied in the System Details page.

Environment

VMware Aria Suite Lifecycle 8.18

Cause

This is an intermittent issue potentially caused by a race condition between script execution and the halting of Java services.

Resolution

Resolution

If the patching task appears stuck in the UI, you can validate that it has completed successfully in the backend and then safely cancel the UI task.

  1. Check the patch log file at /var/log/vrlcm/patchcli.log and look for the following completion messages near the end of the file:
    Restarting server
    2025-07-23 17:57:27,574 - __main__ - INFO - patch installation process ended.
    2025-07-23 17:57:27,579 - __main__ - INFO - patch installation completed.
  2. If these messages are present, the patch installation was successful. You can now navigate to the Requests page in the UI and cancel the stuck task.

Additional Information

The issue is mentioned in the VMware Aria Suite Lifecycle 8.18 release notes.