Device Alarm Policy is not triggering an alarm
search cancel

Device Alarm Policy is not triggering an alarm

book

Article ID: 407944

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

A device level Alarm Policy was created to override a group policy setting, but the device policy is not being honored.

Environment

  • UIM 23.4
  • Operator Console Alarm Policies 

Cause

Metric data was originally collected in long or short name for source and the configuration was changed to the opposite at some point.

When the device level Alarm Policy is created to override the group, the initial QoS source designation is used by the application, and when the plugin_metric.cfg is updated on the downstream robot, it is updated with the wrong source designation.

Resolution

To resolve this the QoS will need to be merged to the current configuration. As an example cdm QoS data was coming in with long name for a period then that changed to short name via the selection of 'Send short name for QOS source' in the cdm configuration:

  1. Open Service Level Management in Operator Console
  2. Select Active QoS Objects
  3. Search for the robot in question
  4. Select the duplicate sources (one with long name and one with the short name for the same metric)
  5. Select Merge Objects
  6. Make sure the direction of the merge is to the short name (for the specific scenario specified above)
  7. Merge
  8. Delete the existing device Alarm Policy, and verify it has been removed from the devices ...Nimsoft/plugins/plugin_metric/plugin_metric.cfg
  9. Create a new device level Alarm Policy with the same information
  10. Confirm that the short name is now listed in the plugin_metric.cfg for the device level override