"Error opening socket to server with message: Connection timed out. ERRORCODE=-4499, SQLSTATE=08001". App connection timeout with DB2 database
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"Error opening socket to server with message: Connection timed out. ERRORCODE=-4499, SQLSTATE=08001". App connection timeout with DB2 database

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Article ID: 407931

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Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

Your application that is deployed with TAS / TPCF is throwing the following errors:

# Main Error:
[APP/PROC/WEB/1] [OUT] Caused by: com.ibm.db2.jcc.am.DisconnectNonTransientConnectionException: [jcc][t4][2043][11550][4.33.31] Exception java.net.ConnectException: Error opening socket to server EXAMPLE.COM/162.x.x.x on port 3,650 with message: Connection timed out. ERRORCODE=-4499, SQLSTATE=08001"

# Subsequent Errors:
[APP/PROC/WEB/1] [OUT] DataSource health check failed
[APP/PROC/WEB/1] [OUT] org.springframework.jdbc.CannotGetJdbcConnectionException: Failed to obtain JDBC Connection
[APP/PROC/WEB/1] [OUT] Caused by: java.net.ConnectException: Connection timed out



 

Cause

"Caused by: com.ibm.db2.jcc.am.DisconnectNonTransientConnectionException:"

  • The database being referred to (db2) cannot be reached from TAS / Diego cell.  As the "Main Error" above indicates in the log line above, the app is complaining about ibm.db2 (an AI- Powered IBM managed database). 
  • This is indicative of some network or database issue with IBM and is not related to or managed by TAS platform

Resolution

  • This type of issue is related to either the users internal network, or is a database issue with IBM. 
  • It is recommended that the user further investigate their network internally and/or database provider (IBM Support) for root cause and resolution.