VCF Automation Organization Services shows "Services are not available for this namespace, try again later or check with your administrator." for a given namespace.
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VCF Automation Organization Services shows "Services are not available for this namespace, try again later or check with your administrator." for a given namespace.

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Article ID: 407830

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • To reproduce the issue:
    • Create a supervisor using NSX VPCs and AVI
    • Create an organization in the VCF Automation Provider Portal
    • Access the created Organization/Tenant Portal
    • Complete the initial configuration for the Organization/Tenant
    • Create a project and and also a namespace
  • In that project one should see the services available in that namespace. But nothing shows up there so you can not create any VMs, VMware Kubernetes Services clusters, etc.
  • User receives the error:
    • Services are not available for this namespace, try again later or check with your administrator.

 

  • This can also manifest in errors in deploying images from Catalog in VCFA 9 where you may face the error:
    • Some data cannot be retrieved. If the problem persists, contact your system administrator. Failed request: /data/namespaces.; Some data cannot be retrieved. If the problem persists, contact your system administrator. Failed request: projects.; [1][namespace.valueList][/data/namespaces] Error getting external data: 500 OK; [2][project.valueList][projects] Error getting external data: 500 OK;
  • The API response from browser will have below message

       

 

Environment

  • VCF Automation 9.0

Cause

  • This is related to a known issue in VCFA 9.0 where the Root CA Certificate for the Supervisor Management Endpoint is not trusted by the VCF Automation.
  • If the Root Certificate Authority Certificate is changed for the Supervisor Management Endpoint since originally registering the vCenter with the VCF Automation Tenant Manager then this is not automatically updated and reflected in the VCF Automation Tenant Manager Trust Store, resulting in a discrepancy and ultimately in this issue presenting.

Resolution

    • Issue is resolved in VCF Automation 9.0.1
    • To remediate this issue please complete the following steps:

      1. Access the VCF Automation Provider Portal (https://yourvcfafqdn.domain.local/provider/)
      2. go to menu "Certificate Management" (VCF Automation Provider Portal > Administration > Certificate Management)
      3. Click "TEST REMOTE CONNECTION" and enter "https://IpAddressForSupervisorManagementEndpoint", click "CONNECT" and verify that the certificate presented isn't trusted.
      4. Cancel this "Trust Certificate" and, in the list of Trusted Certificates, remove the entry for  "supervisor..IpAddressForSupervisorManagementEndpoint"
      5. Navigate to "Connections" (VCF Automation Provider Portal > Administration > Connections), click the 3-dots menu next to the relevant vCenter, then select "Refresh" as shown below.
      6. Wait for the task 'Refreshing VirtualCenter....' to complete.
      7. Observe that a record for "supervisor..IpAddressForSupervisorManagementEndpoint" has been recreated in the Trusted Certificate list (see Step 4 above)
      8. Redo Step 3 and observe that the connection now succeeds.
      9. Open the Tenant Portal for the related Organization.
      10. Navigate to the relevant Namespace.
      11. Observe that all services are now displayed.