One or more nodes in an Aria Operations cluster remain stuck on:
"Waiting for Analytics"
This prevents the cluster from reaching a fully operational state. The issue may occur after a reboot, outage, upgrade, or environmental change.
Note: It is normal for the nodes to be "Waiting for Analytics" for 5 - 10 minutes during start up.
Environment
Aria Operations 8.x and later
Cause
The "Waiting for Analytics" state is a transitional condition that indicates the analytics engine has not successfully initialized. Common root causes include:
Name resolution failures (DNS misconfigurations)
Storage or I/O saturation or full partitions
Time synchronization drift (NTP)
Memory exhaustion
Start up order
Continuous Availability replication, latency, or start up issues
Resolution
These articles are listed in the order of the most likely cause. Start with the Tier 1 articles (Core infrastructure, Configuration Issues, and Cluster Integrity) first, and move to the Tier 2 articles (Continuous Availability if in use and Upgrade Issues if this is happening during an Upgrade) second. Tier 1 issues could be affecting a Continuous Availability cluster as well as a cluster being Upgraded.
Restarting all nodes after bringing the cluster Offline , the cluster status stays on "Going Online" and nodes show "Waiting for analytics..." for more than an hour
Primary replica node status changes to "Waiting for analytics" while the cluster state becomes "Degraded"
Continuous Availability has very strict latency and packet loss threshold requirements. If these thresholds are breached consistently, Continuous Availability will not function properly.