Virtual Machine to Virtual Machine ICMP Communication Failure.
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Virtual Machine to Virtual Machine ICMP Communication Failure.

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Article ID: 407770

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • VMs residing on different hosts unable to ping each other on the same network.
  • Even after moving the VMs to the same host and same port group, ping between VM's still failed.
  • Ping to the default gateway from VMs succeeded.
  • Domain logins are successful on a VM console window.
  • esxtop shows bidirectional network traffic on the VM connections.

Environment

  • VMware vCenter Server 
  • VMware vSphere ESXi 

Cause

Windows Defender Firewall profiles are blocking ICMP (ping) traffic in the VM.

Resolution

Verify that the virtual machine guest operating system Windows Defender firewall settings are configured properly.

Verifying and Configuring Windows Defender Firewall Profiles

  • Open Firewall Settings

    Go to Start > Control Panel > Windows Defender Firewall.

Check Advanced Settings

  1. In the left-hand menu, click Advanced settings. This will open the Windows Defender Firewall with Advanced Security console.
  2. Verify the status of each profile (Domain, Private, Public) to see whether the firewall is Enabled or Disabled.

Modify Firewall State

  • In the console, click Windows Defender Firewall Properties.
  • For each profile, change the Firewall state to Disabled.

Note:
It is recommended to configure application-specific inbound rules to allow ports (such as RDP, ICMP etc.) rather than completely disabling the firewall. 
To edit the specific inbound rules, please refer Configure Firewall Rules With Group Policy | Microsoft Learn or engage Microsoft Support for further assistance. 

Additional Information

Run esxtop via a Putty session, then hit the 'n' key for networking, the VM's connection status and vmnic can be determined from the list.

For related information, see Troubleshooting virtual machine network connection issues (1003893)