File Server Health alert: DNS forward and reverse lookup are not working or incorrect.
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File Server Health alert: DNS forward and reverse lookup are not working or incorrect.

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Article ID: 407761

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • In vSAN Skyline Health, the File Server Health will appear in red with below errors:

vCenter UI>vSAN Cluster>Monitor>Skyline health

  • The above messages are also seen in  /var/run/log/vsanfs.mgmt.log:

2025-10-09T09:35:40.822Z In(14) vsand[2103948]: [opID=#####-### VsanFileServiceSystemImpl::_QueryFileServerHealth] Append container health: (vim.host.VsanFileServerHealthSummary) {
2025-10-09T09:35:40.822Z In(14)[+] vsand[2103948]:   domainName = '***.com',
2025-10-09T09:35:40.822Z In(14)[+] vsand[2103948]:   fileServerIp = '##.##.##.##',
2025-10-09T09:35:40.822Z In(14)[+] vsand[2103948]:   nfsdHealth = 'green',
2025-10-09T09:35:40.822Z In(14)[+] vsand[2103948]:   networkHealth = 'green',
2025-10-09T09:35:40.822Z In(14)[+] vsand[2103948]:   rootfsHealth = 'green',
2025-10-09T09:35:40.822Z In(14)[+] vsand[2103948]:   description = 'File server runtime is in good state.\nBoth DNS forward and reverse lookup are not working or incorrect.',

  • Reviewing the logs in /var/run/log/vsanfs.mgmt.log, you may see entries similar to:

2025-10-09T09:40:59.157Z Wa(12) vsanfs.mgmt[2103701]: [2103862] [VDFSEndpointMonitorContainer::_CheckContainerHealthItem] CONT: Error running DnsLookupTest on container File server node IP "##.##.##.##": dnsbothlookuperror, Forward lookup output:;; communications error to DNS server IP#53: host unreachable

  • vSAN File Service VMs in the cluster cannot ping each other.

Environment

VMware VSAN 8.x

Cause

This indicates a network connectivity issue, where the vSANFS VM is unable to reach the DNS server or communicate with peer vSANFS VMs.

Resolution

  1. Validate Uplinks

    • Navigate to the affected vCenter Port Group

    • Go to Configure > Policies

    • Confirm that the correct uplinks are assigned

  2. Verify VLAN Configuration

    • Ensure that the correct VLAN tags are applied in the same port group configuration.

  3. Engage Network team or vendor to further investigate the issue.