PAM version not upgraded after upgrade reboot
search cancel

PAM version not upgraded after upgrade reboot

book

Article ID: 407746

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Sometimes performing an upgrade of CA PAM, it indicates it is going to reboot the appliance, and after some time the GUI comes back

However, logging in to the GUI still shows the old version, or it sometimes may show the new version but it is not fully functional

Cause

One of the possible causes for this is that the appliance has actually not rebooted

The system tries to reboot to load the upgraded environment, but for instance it may time out synching to disk

In this situation it is even possible that part of the upgrade has taken place (like showing the new version) but that the part of the process that happens upon reboot (for instance reencryption of disk if this is necessary, or loading a new DB schema) has not been completed, leading to an inconsistent situation

Resolution

One of the things that can be attempted if there is suspicion of such a situation is to restart the appliance from the Virtualization console (ESX, Azure...). That will actually trigger the pending changes and the appliance will be upgraded