Warning: 'vSAN Support Insight - Issue with internet connectivity.' on vSAN skyline health for internet enabled vCenter server.
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Warning: 'vSAN Support Insight - Issue with internet connectivity.' on vSAN skyline health for internet enabled vCenter server.

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Article ID: 407677

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • vSAN skyline health for the cluster shows warnings under  vSAN Support Insight - Issue with internet connectivity and Performance diagnostics: Unavailable when Support Insight has issue.

  • vCenter has been configured to have internet. However the warnings would show up.

Environment

VMware vSAN 7.x

VMware vSAN 8.x

Cause

The issue is seen when the backend network/firewall is blocking the internet communication with vCenter network.

This can be validated by running the command on vCenter server command line interface. 

curl -v vcenter.example.com

The example output below would show the communication issues with internet.

# curl -v vcenter.example.com
* Uses proxy env variable no_proxy == 'localhost, 127.0.0.1'
* Uses proxy env variable http_proxy == 'http://##.##.##.##:3128/'
*   Trying ##.##.##.##:3128...
* connect to ##.##.##.## port 3128 failed: Connection refused
* Failed to connect to ##.##.##.## port 3128 after 1 ms: Couldn't connect to server
* Closing connection 0
curl: (7) Failed to connect to ##.##.##.## port 3128 after 1 ms: Couldn't connect to server

Resolution

Fix the network issues/blockers at physical network layer and enable the communication with vCenter to access internet.

Additional Information