How to renew expiring secret token of the Azure Entra ID in vCenter
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How to renew expiring secret token of the Azure Entra ID in vCenter

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Article ID: 407646

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Microsoft Azure Entra ID IDP configured in vCenter has a "Secret Token" about to expire.

Environment

vCenter server 8.x

Cause

The client secret key on Microsoft Azure is near to expiry.

Resolution

To renew shared secret follow the below steps:

1. Log in to the Azure Portal:

  • Navigate to https://portal.azure.com and log in with your credentials.

2. Locate Your App Registration:
  • In the left-hand menu, select "Azure Active Directory."
  • Under "Manage," select "App registrations."
  • Find and select the app registration corresponding to the app ID '####-####-####-####-############'.
3. Add a New Client Secret:
  • Under "Manage," select "Certificates & secrets."
  • In the "Client secrets" section, click "New client secret."
  • Add a description for the new client secret (e.g., "New client secret").
  • Click "Add."
4. Update Your vCenter with the New Client Secret:
  • After creating the new client secret, copy the value displayed. 
  • Update your vCenter's configuration with the new client secret value.

Additional Information