Resync/Edit Service Mesh Fails with Error message: "Login to cloud https://##.##.##.## failed, with status 401"
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Resync/Edit Service Mesh Fails with Error message: "Login to cloud https://##.##.##.## failed, with status 401"

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Article ID: 407639

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Updated On:

Products

VMware HCX

Issue/Introduction

  • Resync or editing the service mesh fails with the following error: "initiateServiceMeshOperation Failed. Reason: Login to Cloud https://##.##.##.## failed, with status 401".  This error can appear in one or more service messages.  
  • Logging directly into Cloud  using the same account is successful.  
  • Pinging from source HCX to destination HCX is also successful.

Environment

HCX 4.11

Cause

  • The account used to register vCenter via the HCX Admin UI was not part of the vSphere Administrators group, resulting in a 401 error being displayed on the UI.
  • The copy of the credentials used on the HCX Manager to register with the vCenter are expired.
  • The account password used to register HCX with vCenter is out of date.

Resolution

Add the user to the Administrators group, or modify the HCX configuration to use a user that is already part of the Administrators group.

  • To update or modify the account used by HCX, access the appliance management interface at https://<hcx-ip-or-fqdn>:9443 and navigate to Configuration -> vCenter Server, and click on 'Edit':




  • Restart the Appliance Management and Web Management from "Appliance Summary" page.
  • Log out and then log back into the vCenter UI.

Additional Information

The account used to register vCenter via HCX Admin UI page must belong to the vSphere administrators group and have the administrator role assigned.
For more information, check HCX Manager User Account and Role Requirements

If the issue persists, also check the following KB:

- Unable to register vCenter SSO with HCX