One or more NSX Manager appliance does not boot up
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One or more NSX Manager appliance does not boot up

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Article ID: 407633

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Updated On:

Products

VMware NSX

Issue/Introduction

One or more of the NSX Manager appliances (from a cluster of 3) is unable to boot up as a result of storage corruption in it's disk due to an underlying storage infrastructure issue.

In some cases the storage corruption may be so severe, that all 3 NSX Manager appliances cannot boot up. As a result the NSX Manager cluster may look degraded as follows:

Environment

VMware NSX

Cause

Underlying storage issue

Resolution

In such cases it's possible to restore NSX Managers from a recent backup once the underlying storage is fixed and available.

Follow these steps to restore an NSX manager appliance from backup:
1. Deploy one NSX Manager appliance of the same version and build number as the damaged ones into the same vCenter cluster where the old ones were
2. Assign the same IP / hostname / FQDN to this NSX Manager as one of the old ones and connect it to the same DVS portgroup as the old ones
3. Power it up and access it's UI
4. Click on System -> Backup and Restore and click Edit to add the SFTP server
5. Configure the same SFTP server as the old ones so that the previous backups become visible
6. Select the appropriate backup file and click restore
7. Once the restore is complete, deploy two new NSX Manager appliances using the same IPs and FQDNs as the old ones to form a cluster of three.

Additional Information

Detailed information about the NSX Manager Restore process is available in the NSX Admin Guide here: Restore a Backup