HBR service fails on Cloud Director Availability replicator with "Panic: Assert Failed"
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HBR service fails on Cloud Director Availability replicator with "Panic: Assert Failed"

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Article ID: 407626

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Updated On:

Products

VMware Cloud Director VMware Cloud Director Availability - Migration 4.x VMware Cloud Director Availability - Disaster Recovery 4.x

Issue/Introduction

On the replicator appliance for VMware Cloud Director Availability the HBR service will intermittently come up and fail. In the /var/vmware/log/hbrsrv logs there will be an error similar to the following:
 2025-08-06T06:54:16.442Z info hbrsrv[09941] [Originator@6876 sub=Misc opID=hs-init-4555263a] Instance mgmt starting sync prune for group H4-############################
 2025-08-06T06:54:16.443Z panic hbrsrv[09941] [Originator@6876 sub=Default opID=hs-init-4555263a]
 -->
 --> Panic: Assert Failed: 'key.IsNull()' @ bora/apps/hbr/hbrsrv/src/DiskPrune.cpp:2026
 --> Backtrace:
 --> [backtrace begin] product: VMware vSphere Replication Server, version: 8.0.3, build: build-23960048, tag: hbrsrv, cpu: x86_64, os: linux, buildType: release
 --> backtrace[00] hbrsrv-bin[0x00B39362]
 --> backtrace[01] hbrsrv-bin[0x00B2C0C7]
 --> backtrace[02] hbrsrv-bin[0x00CCB6A8]

Environment

VMware Cloud Director Availability 4.7.3

Cause

There is bad data in the hbrsrv database. This can be caused by a replicator entering maintenance mode when not in a healthy state.

Resolution

Open a support request with Broadcom VCF support referencing this article.