CF task is not visible in AppsManager UI.
search cancel

CF task is not visible in AppsManager UI.

book

Article ID: 407554

calendar_today

Updated On:

Products

VMware Tanzu Platform - Cloud Foundry

Issue/Introduction

CF Tasks are not visible in Apps Manager UI however the tasks runs without problem.

 

  • When listing cf tasks it throws "UnknownError","detail":"An unknown error occurred.","code":10001
ubuntu@opsmgr-tanzu:~$ cf tasks kuard
Getting tasks for app kuard in org test / space test as admin...Unexpected Response
Response Code: 500
Request ID:    637f59a7-b178-4cdc-xxxx-be19f0ef5686::3750c3c2-9329-xxxx-8b2a-b3da72933337
Code: 0, Title: , Detail: {"errors":[{"title":"UnknownError","detail":"An unknown error occurred.","code":10001}]}
FAILED 

 

  • Cloud_Controller logs reports below error message :
{"timestamp":"2025-08-13T10:21:35.788477497Z","message":"Request failed: 500: {\"errors\"=\u003e[{\"title\"=\u003e\"UnknownError\", \"detail\"=\u003e\"An unknown error occurred.\", \"code\"=\u003e10001, \"test_mode_info\"=\u003e{\"detail\"=\u003e\"docker? delegated to droplet, but droplet is nil\" 

 

  • Apps Manager Ui shows no tasks for application.

Environment

Tanzu Platform for Cloud Foundry 10.0.8 with CAPI version 1.212.0.

Cause

The root cause is that older droplet get's cleaned up and the task presenter is tolerant to it. Subsequent pushes will cause the original droplet to get cleaned up and deleted and any tasks referring to deleted droplets can no longer fetch the docker user from it for display.

Resolution

The fix has been implemented in the new CAPI release. CAPI version 1.213.0

It will be fixed in the upcoming TPCF release which include's CAPI version 1.213.0.