PAM-CM-0769 Occurring For All Target Account Update Attempts
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PAM-CM-0769 Occurring For All Target Account Update Attempts

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Article ID: 407497

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

We are having an issue where two of our PAM nodes are not updating passwords for any accounts. When the password attempt is made, the system responds with the following error message.

PAM-CM-0769: Account update in progress, unable to process request.

 

Cause

When a target account is updated in PAM, Tomcat will use Hazelcast to communicate with the other appliances to verify the account is not already being updated on another appliance. In the Tomcat logs for both problem appliances, there were Hazelcast errors dating back to a prolonged cluster communication outage that had occurred over the weekend that caused the Hazelcast instance to no longer be active on the appliance.

025-08-13T11:58:57.109+0000 WARNING [TP14] com.cloakware.cspm.server.app.LockManager.isLock T#####: LockManager.isLock Failed to test type[TargetAccountImpl45003]
com.hazelcast.core.HazelcastInstanceNotActiveException: HazelcastInstance[[PAM IP ADDRESS]:5900] is not active!

Resolution

To resolve the issue, go to the Clustering configuration page and resync any appliances that are experiencing the error.