Opsman UI/API inaccessible during Apply Changes
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Opsman UI/API inaccessible during Apply Changes

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Article ID: 407492

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Updated On:

Products

Operations Manager

Issue/Introduction

During an apply changes, the Opsman UI and/or API may stop responding and eventually time out

Environment

Opsman v3.0.20 or later

Cause

In Opsman v3.0.20, the web server was replaced with Puma. The current connection pool size is 5

If multiple people are trying to view the apply changes page at the same time, the connection pool can become full and Opsman will stop responding.

Resolution

The following workaround will increase the connection pool size from 5 to 20

  1. Export Opsman installation settings and keep it in a safe place
  2. SSH into Opsman
  3. Edit the puma prodcution.rb config
    1. sudo vim /home/tempest-web/tempest/web/config/puma/production.rb
    2. Add threads 20, 20 to the end of the configuration
    3. Example production.rb:
      1. # See: vm/appliance-construct/create-nginx-conf/nginx.conf:35
        bind 'unix:///tmp/tempest-web.sock'

        first_data_timeout 3610
        persistent_timeout 3610

        # increase threads
        threads 20, 20

  4. Wait for any running apply changes to complete before the next step
  5. Restart tempest web

    1. sudo service tempest-web restart

  6. Enter decryption passphrase on the Opsman UI