Update Foundation Load Balancer (FLB) DHCP Config after DHCP Server Changes
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Article ID: 407470
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Updated On:
Products
VMware vSphere Kubernetes Service
Issue/Introduction
The FLB management network is configured to use DHCP. After the DHCP server is modified — for example, when the DHCP IP range is updated — the FLB VM continues to use its old lease and does not acquire a new IP address. As a result, the Foundation Load Balancer may report an xDS Connection Down error, and the status becomes unhealthy.
Environment
VCF 9.0.0
Supervisor is deployed with Load Balancer Type of Foundation Load Balancer
Cause
The FLB VM is unaware of the changes to the DHCP server and will not attempt to renew its DHCP lease until the current lease is close to expiration. Therefore, it continues to use the old IP configuration, which may no longer be valid.
Resolution
Perform the following steps to reconfigure the FLB network interface and trigger a new DHCP request, allowing it to obtain an IP address from the updated DHCP configuration:
Navigate to the vCenter Main Menu. Open the Foundation Load Balancers section from the drop-down menu.
Locate the unhealthy FLB instances and check the management IP
Login to the FLB instance with the username vmware-system-user. The password can be reset via Change password in the UI.
If the management IP is still reachable from the LAN, you can SSH to the affected foundation loadbalancer instance using SSH.
If the management IP is not reachable, you will need to find the ESXi instance of the foundation loadbalancer instance and login via the ESXi web console.
Run ip a to check the name of the interface that has the wrong DHCP lease. It should be one of eth0, eth1 or eth2.
Run networkctl reconfigure ethX to obtain a new DHCP lease. ethX should be replaced by the name from the previous step.