Messaging Gateway license registration fails with "Peer certificate has expired" error
search cancel

Messaging Gateway license registration fails with "Peer certificate has expired" error

book

Article ID: 407446

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

When attempting to license a Messaging Gateway system at system installation via the Setup Wizard, the registration attempt fails with the following error:

Cannot register the specified file.
Unable to communicate with Symantec to register. Please check your connection settings and try again. Connection error 60: Peer's certificate has expired.

 

Cause

The date and time on the virtual machine that SMG is being installed to is incorrect and outside the certificate validity date rance for https://register.brightmail.com. This is usually caused by the system clock on the underlying virtual machine server not being set correctly.

Resolution

Ensure that the system clock on the virtual machine server is set to the correct data and time. Ideally, the virtual machine server should be configured to use network time synchronization (NTP) to ensure that the system clock does not drift from the correct time.