Registering or adding a Compute Manager to NSX fails with error code 7058
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Registering or adding a Compute Manager to NSX fails with error code 7058

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Article ID: 407415

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When registering/adding a Compute Manager in NSX-T, fails with error
    Compute manager server value <vCenter> could not be connected, server might be unreachable or connection details might be invalid. If the issue persists, please check whether the HTTPS and HTTP ports of compute manager are open in the firewall on all NSX nodes. (Error code: 7058)
  • The following error may be seen in /var/log/cm-inventory/cm-inventory.log
    <Date>T08:06:00.791Z  WARN http-nio-127.0.0.1-7443-exec-5 VcUtilsImpl 6082 SYSTEM [nsx@6876 comp="nsx-manager" level="WARNING" reqId="request ID" subcomp="cm-inventory" username="admin"] Exception in getting vc thumbprint
    java.net.SocketException: Connection reset

Environment

VMware NSX

Cause

This error can be the result of any condition that can interrupt NSX Manager network connection to the Compute Manager (vCenter Server) .

Resolution

Verify that physical network connectivity between the NSX Manager and vCenter Server is successful, then re-add the Compute Manager.

Note, while ports 443 and 80 are required for connection, ensure also that SSL is also allowed over port 80 on any physical firewalls, see "Failed to remove NSX ownership due to error Error in rest call" error and Compute Manager status down

Additional Information

Recommended validation checks for troubleshooting CM to NSX connectivity issues: