SRM DR UI/VAMI is not accessible Error - "This site can't be reached"
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SRM DR UI/VAMI is not accessible Error - "This site can't be reached"

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Article ID: 407255

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • While Launching Site Recovery DR UI display below error,

  • Error shown while accessing SRM VAMI ,

  • In vmware-dr.log found below failed error,

    SRM solution user creation fails to complete on vCenter server at 500 internal server error.

    xxxx-xx-xxT15:51:24.257+08:00 verbose vmware-dr[21708] [SRM@6876 sub=IO.Connection opID=7dd0e4c1-8fac-4cf0-93ab-f10d7c850b84-createSolutionUser] Attempting connection; <resolver p:0x00007f5934915f30, 'VChostname.xxx.xxx:443', next:<TCP 'xxx.xxx.xxx.xx : 443'>>, last e: 0(Success)xxxx-xx-xxT15:51:24.323+08:00 warning vmware-dr[21714] [SRM@6876 sub=vmomi.soapStub[13357] opID=7dd0e4c1-8fac-4cf0-93ab-f10d7c850b84-createSolutionUser] SOAP request returned HTTP failure; <SSL(<io_obj p:0x00007f59287a5fa8, h:23, <TCP 'xxx.xxx.xxx.xxx : 35888'>, <TCP 'xxx.xxx.xxx.xx : 443'>>),/sso-adminserver/sdk/vsphere.local>, method: addUserToLocalGroup; code: 500(Internal Server Error)

Environment

VMware Site Recovery Manager 8.x

Cause

  • This is due to SRM hostname conflicts between lowercase and uppercase hostnames that are stored in the DNS of the same environment.

  • Issue occurs if DNS records has IP configured with multiple hostnames, ideally same hostname one in upper case "SRMHOSTNAME.XXX.XX" and another in lower case "srmhostname.xxx.xx".  

    The SRM IP xxx.xxx.xxx.xxx nslookup is resolved with upper case hostname SRMHOSTNAME.XXX.XX , and vice versa. Refer below screenshot

    root [ /home/admin ]# nslookup SRMHOSTNAME.XXX.XX
    xxx.xxx.xxx.xx
    xxx.xxx.xxx.xx#53

    SRMHOSTNAME.XXX.XX
    Address: xxx.xxx.xxx.xxx

    root [ /home/admin ]# nslookup xxx.xxx.xxx.xxx
    xxx.xxx.xxx.xxx.in-addr.arpa  name = SRMHOSTNAME.XXX.XX.


    While Lower-case SRM hostname srmhostname.xxx.xx nslooup  is resolved by SRM IP xxx.xxx.xxx.xxx, but when SRM IP nslookup is being conducted, it only resolves hostnames in uppercase SRMHOSTNAME.XXX.XX. The vCenter server's SRM lookup service is failing because the lowercase hostname is functioning as stale. Refer below  result.

    root [ /home/admin ]# nslookup srmhostname.xxx.xx
    Server: xxx.xxx.xxx.xx
    Address: xxx.xxx.xxx.xx#53

    Name:   srmhostname.xxx.xx
    Address: xxx.xxx.xxx.xxx

    root [ /home/admin ]# nslookup xxx.xxx.xxx.xxx
    xxx.xxx.xxx.xxx.in-addr.arpa name = SRMHOSTNAME.XXX.XX.

Resolution

It is necessary to eliminate duplicate DNS entries and retain only one entry for the hostname, either in upper or lower case, that resolves the SRM IP.

Once Single entries are maintained in the DNS server, reconfigure the SRM appliances using Hostname/FQDN.

Workaround:

Reconfigure SRM appliances with IP instead of FQDN. This will resolved IP only with Hostname in upper case.

Additional Information