Newly created luns not visible to the ESXi hosts
search cancel

Newly created luns not visible to the ESXi hosts

book

Article ID: 407251

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • Newly created luns on a Storage array are not visible to ESXi hosts.
  • Despite re-scanning the FC adapter on the ESXi host, the luns are not visible.

Environment

VMware vSphere ESXi 7.0.x

VMware vSphere ESXi 8.0.x

 

Cause

This can be caused by the storage array target rejecting PLOGI request from the initiator (HBA).

Validation:

  • The /var/log/vmkernel.log  file on the ESXi host these messages pertaining to Fibre Channel  communication between an initiator (HBA) and a target (e.g., a storage array)  rejecting a Port Login (PLOGI) request.

2025-07-30T15:28:46.751Z cpu24:2097893)nfnic: <2>: INFO: fdls_process_tgt_plogi_rsp: 1726: PLOGI returned FC_LS_REJ from target: 0xcf0a80

  • This log entry in  /var/log/vmkernel.log file is from the Cisco FNIC driver, indicating an frame reset where the host forcibly terminated a Fibre Channel session with the target.

2025-07-30T15:28:46.751Z cpu24:2097893)nfnic: <2>: INFO: fnic_tport_exch_reset: 4896: Tport exch reset: target id: 2 tport->fcid: 0xcf0a80

  • The above logs indicate that PLOGI rejections are occurring on target ports belonging to a storage array.

 

Resolution

Engage the storage and fabric vendors to investigate and address potential LUN visibility or configuration issues on the storage array and associated fabric paths to the ESXi hosts.

 

Additional Information

Additionally, verify the HBA compatibility with the ESXi version and ensure the HBA firmware and driver are up-to-date and supported.
To validate the driver and firmware version running on the Host Bus Adapters (HBA) refer to this article:  Determining Network/Storage firmware and driver version in ESXi