After changing the IP addresses used in an NSX DHCP Relay Profile, new DHCP requests continue being sent to the original IP addresses
search cancel

After changing the IP addresses used in an NSX DHCP Relay Profile, new DHCP requests continue being sent to the original IP addresses

book

Article ID: 407233

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • The DHCP IP addresses in the NSX DHCP Relay Profile have been changed
  • New DHCP requests from clients on the segments are still sent to the original IP addresses
  • Reboot the NSX Manager or Edge does not resolve the issue

Environment

VMware NSX

Cause

The altered DHCP Relay Profile isn't getting pushed down to the NSX Edges.

Resolution

Delete the NSX DHCP Relay Profile. Note: this can only be done when the profile is unused by any segments. 

It is recommended to perform this process in a maintenance window in case of production impacting issues. 

To perform this the following action plan can be implemented:

  1. Log into the NSX Manager UI with admin credentials
  2. Go to the Networking > Networking Profiles > DHCP 
    1. In the Where Used column click on the number to view where the profile has been implemented (note: if there is a zero in this column, then the profile is not in use). To ensure accurate data, please take a screenshot of the profile for reference during the recreation process. Example shown in below screenshot:
  3. Go to Segments and find the segment(s) that are using the DHCP Relay profile and select the small three dots to the left of the segment name and click Edit.
    1. Select Delete DHCP Config and confirm the deletion
    2. Save the change and close the editing page
  4. Return to the Networking Profiles > DHCP and confirm the Where Used column reflects zero
  5. Proceed with deleting the profile by clicking the small three dots on the left hand side of the profile name and select Delete and Delete again to confirm the deletion of the profile. 
    • Please note that it can take several minutes to be fully removed from the NSX UII.
  6. Proceed with re-creating the DHCP Relay Profile with only the new DHCP IP addresses, and apply it to the Segments that had been associated with it before. 
  7. After the new profile has been applied to the necessary segments, perform a release/renew to confirm if the broadcast requests are now being directed to the correct DHCP IP addresses. 

If the issue is still seen after creating a new DHCP Relay Profile, please open a support case and provide the following logs as well as referencing this KB:

  • NSX Manager
  • ESXi Host logs of the VM that performed the release/renew testing
    • Please include the VM name and VM IP address
  • NSX Edge 
  • Please provide the DHCP IP addresses as well (both the previous IP addresses and the newly implemented IP addresses)

Please also include any other changes to the environment (such as upgrades for example) as well as time stamps for when the above process was performed.