Issue with QR Code Not Working for MFA Registration in Symantec VIP
search cancel

Issue with QR Code Not Working for MFA Registration in Symantec VIP

book

Article ID: 407120

calendar_today

Updated On:

Products

VIP Service

Issue/Introduction

We are encountering an issue in the Self-Service Portal where the QR Code option for MFA registration is not working. As a result, we are forced to rely on email for code delivery, which causes problems for users who do not have access to their email. We would appreciate assistance in resolving the issue with the QR Code functionality so that users can register their devices without relying on email for code delivery.

This article explains how to generate a QR code for credential registration using the RegistrationQRCode REST API. This method is useful for enrolling users who cannot receive registration codes via email or SMS.

Environment

Symantec VIP API

Cause

By default, VIP Self-Service Portal can send a registration code to a user’s registered email or phone number during MFA credential enrollment.
However, in certain cases (e.g., no email access, offline environments, or restricted SMS usage), a QR code can be generated and shared with the user to register their VIP credential directly via the VIP Access mobile app.

Resolution

How to register a VIP Access for Mobile authenticator for a user using a QR code:

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/vip/cloud/vip-web-services-and-apis-v127046027-d2278e2328/VIP-REST-APIs/vip-rest-api-about-the-vip-credential-management-apis/vip-rest-api-registering-vip-access-credentials-using-qr-codes.html 

Use the following APIs to register a VIP Access for Mobile app as an authenticator using a QR code:

    Additional Information

    Use the RegistrationStatus API to check the status of the VIP Access for Mobile QR code registration process.