HCX upgrade via VMware Cloud on AWS[VMC] is stuck
search cancel

HCX upgrade via VMware Cloud on AWS[VMC] is stuck

book

Article ID: 407114

calendar_today

Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

  • HCX upgrade triggered via VMware Cloud on AWS [VMC] console is stuck "Getting eligible versions to upgrade HCX Cloud Manager"
  • HCX is activated on VMC SDDC and is stuck on this screen



  • You followed Upgrade HCX for VMware Cloud on AWS and encountered the above stuck screen.

Environment

HCX deployed on VMware Cloud on AWS

Cause

The VMC console has not yet detected the current HCX version, resulting in the UI getting stuck while attempting to fetch eligible versions for upgrade.

Resolution

  • Please wait for 10-15 seconds at the Integrated Services screen, so that the current HCX version is displayed as shown below.



  • Click ACTIONS > Upgrade and below screen will appear allowing you to select the version you want to upgrade to.




  • Click "UPGRADE" after choosing the target version. The process could take about an hour.

Additional Information