After upgrade of CA Mediation Manager (CAMM), MC WEB GUI is inaccessible with HTTP status 500- internal server error.
search cancel

After upgrade of CA Mediation Manager (CAMM), MC WEB GUI is inaccessible with HTTP status 500- internal server error.

book

Article ID: 407085

calendar_today

Updated On:

Products

CA Mediation Manager Network Observability

Issue/Introduction

After upgrading CAMM to resolve a previous issue, unable to launch MC Web GUI with HTTP status 500- internal server error.

An Jsp Version incompatibility error is shown in the CAMM web catalina.out logs.

 

NOTE:: This was also seen in an issue where there were NO errors in the catalina.out log, but this fix resolved the problem.

Environment

DX NetOps CAMM:: all currently supported releases

Cause

By default, the JVM will understand how to run the application however, there are some configurations in the java/jvm in some environments that can cause an issue, specifically, preventing the GUI from running with an error thrown in the $WEBCAMM/logs/catalina.out:

JSP Version incompatibility 

Hence, you need to add  explicit reference to the JSP version to allow the JVM to run the application.

This issue can also occur after upgrading or patching, where the changes above that were previously done in $CAMM_HOME/WEBCAMM/conf/web.xml are overwritten.

 

Resolution

Add the following in the $CAMM_HOME/WEBCAMM/conf/web.xml file:

<servlet>
  <servlet-name>jsp</servlet-name>
  <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
  <init-param>
    <param-name>compilerSourceVM</param-name>
    <param-value>1.8</param-value>
  </init-param>
  <init-param>
    <param-name>compilerTargetVM</param-name>
    <param-value>1.8</param-value>
  </init-param>
  <load-on-startup>3</load-on-startup>
</servlet>

Then restart the CAMM services.