Unable to read IBM storage array from ESXi host
search cancel

Unable to read IBM storage array from ESXi host

book

Article ID: 407070

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

After hosts reboot, the hosts can no longer communicate with the IBM storage array.

In vmkernel.log you see the following messages:

2025-08-10T18:55:10.398Z cpu38:2097853)lsi_msgpt3: _scsih_add_device:3057: lsi_msgpt3_0: detecting: handle(0x0009), sas_address(0x500507680d051940), phy(0)
2025-08-10T18:55:10.398Z cpu38:2097853)lsi_msgpt3: _scsih_report_luns:2596: lsi_msgpt3_0: REPORT_LUNS: handle(0x0009)
2025-08-10T18:55:10.400Z cpu38:2097853)lsi_msgpt3: _scsih_test_unit_ready:9378: lsi_msgpt3_0: TEST_UNIT_READY: handle(0x0009), lun(0)
2025-08-10T18:55:10.400Z cpu38:2097853)lsi_msgpt3: _scsih_add_device:3065: lsi_msgpt3_0: _scsih_add_device - device not ready: slot(0)
2025-08-10T18:55:10.400Z cpu38:2097853)lsi_msgpt3: _scsih_add_device:3076: lsi_msgpt3_0: _scsih_add_device - device not ready: enclosure level(0x0000), connector name( 0   )
2025-08-10T18:55:10.400Z cpu38:2097853)lsi_msgpt3: _scsih_add_device:3057: lsi_msgpt3_0: detecting: handle(0x000a), sas_address(0x500507680d051941), phy(4)
2025-08-10T18:55:10.400Z cpu38:2097853)lsi_msgpt3: _scsih_report_luns:2596: lsi_msgpt3_0: REPORT_LUNS: handle(0x000a)
2025-08-10T18:55:10.401Z cpu38:2097853)lsi_msgpt3: _scsih_test_unit_ready:9378: lsi_msgpt3_0: TEST_UNIT_READY: handle(0x000a), lun(0)
2025-08-10T18:55:10.401Z cpu38:2097853)lsi_msgpt3: _scsih_add_device:3065: lsi_msgpt3_0: _scsih_add_device - device not ready: slot(4)
2025-08-10T18:55:10.401Z cpu38:2097853)lsi_msgpt3: _scsih_add_device:3076: lsi_msgpt3_0: _scsih_add_device - device not ready: enclosure level(0x0000), connector name( 1   )

Environment

vSphere ESXi (All Versions)

IBM Storage array

Cause

This is caused if none of the LUNs are configured with a SCSI ID of 0. A SCSI ID of 0 is required to initiate the test unit ready commands to the array to establish the paths to the LUNs on the array. See IBM doc Troubleshooting SCSI device not seen by operating system

Resolution

To resolve this do the following:

  1. Reconfigure one of the LUNs to have a SCSI ID of 0
  2. Reboot the host

If assistance is required with step 1 engage IBM Support.