NSX Native Load Balancer Server Pools and Virtual Servers show status DOWN with a related NSX object greyed out in the NSX UI.
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NSX Native Load Balancer Server Pools and Virtual Servers show status DOWN with a related NSX object greyed out in the NSX UI.

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Article ID: 407045

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX Native Load Balancer Virtual Servers and Server Pools show Status as Down. 

  • When investigating the NSX objects (T1, segments, etc) associated with this Load Balancer configuration, one or more objects are found to be grayed out, and in Unknown status. 

  • In the NSX Manager nsxapi logs, may see log prints similar to the following indicating a DELETE action is underway for the object, even if the delete action ultimately failed. 
    • This example is related to an NSX segment that was stuck in DELETING state after it failed to successfully delete. The NSX Native Load Balancer was connected to a T1 which had a service interface attached to this segment.  

2025-06-19T15:00:00.039Z  INFO policyProviderTaskScheduler-2 ResourceDeletionAsyncValidator 85784 POLICY [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Called validateGlobalResourceChange with /global-infra/segments/######-##-## and DELETING

2025-07-31T02:20:07.829Z  INFO providerTaskExecutor-1-119 LogicalSwitchServiceImpl 85698 SWITCHING [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Request to delete LogicalSwitch : LogicalSwitch/0d3db6ac-####-####-####-1a3460cccd65
2025-07-31T02:20:07.844Z  INFO providerTaskExecutor-1-119 SegmentProviderNsxT 85698 SWITCHING [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Failed to Delete Logical Switch 

Environment

VMware NSX

Cause

A delete request was initiated at some point for an NSX object relevant to the Native Load Balancer workflow but it either failed to complete or was stuck and unable to progress until some other association was cleared away. 

Resolution

There is not a way to cancel a partially completed or failed DELETE action from within NSX. Instead the following workaround is recommended to restore functionality and a case can be opened with Broadcom GS to investigate the NSX logs to try to determine what initiated the DELETE request if it is unknown. 

Workaround:

  • Create new NSX objects to replace those stuck in DELETING state. 
    • May have to create several NSX objects due to various associations with the existing objects that may prevent certain replacements. Also, various different Load Balancer configurations may involve different NSX objects to function. 
    • In the example above related to an NSX segment stuck in DELETING state, the following objects were recreated.
      • New NSX segment was created for the same subnet as the original.
      • New T1 was created with a service interface (same IP as the original) attached to the new NSX segment. 
      • Reconfigured the NSX Native Load Balancer to connect to the new T1. 

Note: Due to the variables involved in this workaround, please open a support case with Broadcom GS to assist with this replacement activity.